CVE-2026-111497

Publication date 23 October 2026

Last updated 29 October 2026


Ubuntu priority

Cvss 3 Severity Score

9.8 · Critical

Score breakdown

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Read the notes from the security team

Why is this CVE high priority?

CISA-KEV

Learn more about Ubuntu priority

Status

Package Ubuntu Release Status
brotli 26.10 stonking
Fixed in 1.2.0-4ubuntu0.1
26.04 LTS resolute
Fixed in 1.2.0-3ubuntu0.1
24.04 LTS noble
Fixed in 1.1.0-2ubuntu0.1
22.04 LTS jammy
Fixed in 1.0.9-2ubuntu0.1
20.04 LTS focal
Fixed in 1.0.7-6ubuntu0.1+esm1
18.04 LTS bionic
Fixed in 1.0.3-1ubuntu1.3+esm1
16.04 LTS xenial
Fixed in 1.0.3-1ubuntu1~16.04.2+esm1
nodejs 26.10 stonking
Not affected
26.04 LTS resolute
Not affected
24.04 LTS noble
Not affected
22.04 LTS jammy
Not affected
20.04 LTS focal
Vulnerable
18.04 LTS bionic
Not affected
16.04 LTS xenial
Not affected
14.04 LTS trusty
Not affected
dotnet6 26.10 stonking Not in release
26.04 LTS resolute Not in release
24.04 LTS noble Not in release
22.04 LTS jammy
Vulnerable, fix deferred
20.04 LTS focal Not in release
18.04 LTS bionic Not in release
16.04 LTS xenial Not in release
14.04 LTS trusty Not in release
dotnet7 26.10 stonking Not in release
26.04 LTS resolute Not in release
24.04 LTS noble Not in release
22.04 LTS jammy Ignored see notes
20.04 LTS focal Not in release
18.04 LTS bionic Not in release
16.04 LTS xenial Not in release
14.04 LTS trusty Not in release
dotnet8 26.10 stonking Not in release
26.04 LTS resolute Not in release
24.04 LTS noble
Fixed in 8.0.133-8.0.33-0ubuntu1~24.04.1
22.04 LTS jammy
Fixed in 8.0.133-8.0.33-0ubuntu1~22.04.1
20.04 LTS focal Not in release
18.04 LTS bionic Not in release
16.04 LTS xenial Not in release
14.04 LTS trusty Not in release
dotnet10 26.10 stonking
Fixed in 10.0.114-10.0.14-0ubuntu1~26.10.1
26.04 LTS resolute
Fixed in 10.0.114-10.0.14-0ubuntu1~26.04.1
24.04 LTS noble
Fixed in 10.0.114-10.0.14-0ubuntu1~24.04.1
22.04 LTS jammy Not in release
20.04 LTS focal Not in release
18.04 LTS bionic Not in release
16.04 LTS xenial Not in release
14.04 LTS trusty Not in release
dotnet11 26.10 stonking
Fixed in 11.0.100-11.0.0~rc3-0ubuntu1~26.10.1
26.04 LTS resolute Not in release
24.04 LTS noble Not in release
22.04 LTS jammy Not in release
20.04 LTS focal Not in release
18.04 LTS bionic Not in release
16.04 LTS xenial Not in release
14.04 LTS trusty Not in release

Get expanded security coverage with Ubuntu Pro

Reduce your average CVE exposure time from 98 days to 1 day with expanded CVE patching, ten-years security maintenance and optional support for the full stack of open-source applications. Free for personal use.

Get Ubuntu Pro 30-day free trial

Notes


mdeslaur

nodejs on jammy and higher uses the system brotli, marking as not-affected nodejs on focal uses the vendored brotli nodejs in bionic and earlier doesn't use brotli at all


iconstantin

.NET 7 is end of life upstream.


mdeslaur

Marking .NET 6 as deferred until information is available to determine if it is impacted.

Patch details

For informational purposes only. We recommend not to cherry-pick updates. How can I get the fixes?

Package Patch details
brotli

Severity score breakdown

CVSS version:

Base score 9.2 · Critical

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Base score 9.8 · Critical

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H


Access our resources on patching vulnerabilities